Skip navigation

Newbie help needed with running issue!!

Post

Back to the top

School boy error ran out of fue

:ocf_emoticons__BangHead::ocf_emoticons__BangHead:It started when I ran out of fuel the car hasn't ran properly since, have since replaced lift pump, accumulator and the main fuel pump and it still fills like it's starving of fuel when running, it starts fine first turn of the key the timing and mixture is all good doesn't seemed to be any loss of vacuum any where, now starting to do my head in with what's caused this issue, is there anyone out there near Devizes that would be willing to come over and take a look that would be awesome I have plenty of home brew cider as a reward to getting it running properly again. Many thanks Ian 

Post

Back to the top
Have you put a fuel filter on? You might have dragged some rust through it. Remove the rear seat and you will have access to the fuel tank. A bit of string with a magnet on will help pull the old rust out. If it's lodged in the card or injector it might be a bit more work. Always keep your tank at least a quarter full.
 

Banner

Post

Back to the top
look in your filler neck to see if it rusting inside if so like your last reply most prob rust in the system hopefully it just in tank blocking your fuel feed hope this helps

rob

Post

Back to the top
Cheers guys got a new fuel filter order so I'll give it a try when it turns up, let you know what happens

Post

Back to the top
did you see any rust in inside of filler neck when you open fuel cap if so replace fuel neck asap as you will just keep getting same problem I fitting one at moment will let you know how easy it is ........... :)
1 guests and 0 members have just viewed this: None.