Skip navigation

No oil lights on dash

Post

Back to the top
Hi All, I am having a problem with my oil pressure light on my dash as it does not come on at all. It used to work before I worked on my engine, but now there is no oil light at all. I do get the battery light when I put the key in and turn the key before I start it,but no oil light. Any ideas where to start. It is a GTI cabriolet, 1.8,  H reg 1991. Thanks in advance.

Post

Back to the top
Make sure all your Sensor connections are on and tight.

It could be a loose connection on the cluster, see my flaky water temp gauge repair on "Plumping the tongue" for the main connector on the Cluster, and it could be that the bulb is bad.

Suspect the connectors on the oil pressure switches first.

What do Divorces, Great Coffee, and Car Electrics all have in common?

They all start with GOOD Grounds.

Where are my DIY Links?

Post

Back to the top

No oil lights on dash

Hi i ve checked all the wire and they are all good with tight connections at the switches.

Sent from my SM-G930F using Tapatalk

Post

Back to the top
Hi all, ok sorted my engine out but still not getting an oil light what can i do to check its not the bulb blown?

Post

Back to the top
Disconnect the oil pressure switch and earth it to the engine/body. The light should come on

Post

Back to the top

No oil lights on dash

I ve tried that but thats no good, also tried to earth the pin 1 to 11 and still got no light. It used to work but when I did my engine rebuild it has stop working.

Sent from my SM-G930F using Tapatalk

Post

Back to the top
http://www.cabby-info.com/Files/InstrumentClusterDiagrams.pdf

This suggests 2 and 11 should put the light on

Post

Back to the top
Ok tried the 2 & 11 together but still no light what next can I try

Post

Back to the top
Change the LED or Bulb which ever is installed.

What do Divorces, Great Coffee, and Car Electrics all have in common?

They all start with GOOD Grounds.

Where are my DIY Links?
1 guests and 0 members have just viewed this: None.