Skip navigation

Red flashing light in temp gauge

Post

Back to the top
Hi all, my car has been under wraps for several months over the winter, i am just starting to use it again today and blow the dust off to get ready for MOT and summer, i noticed earlier that when i started up the car the red light in the temperature gauge kept flashing all the way home (only a short run 5 mins), can anyone tell me what that means? do i have a cooling problem?

Thanks

Steve

Post

Back to the top
Lost any coolant or anything? If you leave the car running does the fan kick in? 

My two things I'd replace first are thermo switch on radiator (this controls when the fan should kick in) 
Then it would be thermostat under water pump, could be stuck open/shut. 

Turn the car in and open the expansion cap should see water trickling in if the pump is working. 

Just my input fella  :thumbs:

Post

Back to the top
Thanks Brad, the fan does kick in and out and the temp stays around half way, BUT sometimes the temp reading drops off so i wonder if i have a faulty thermo also

Steve

Post

Back to the top
The red flashing light is if you are low on coolant, if its ok then it's a couple of thing, there is a sensor in the expantion tank, you can see a wire coming out the top of the tank, if you remove this there is 2 prongs which measure the levels in the tank they get bunged up with crud etc or rust away. Be careful removing and replacing the sensor as its plastic screwed into plastic, have some PTFE tape handy in case you can't seal it once its been removed. If they are ok it could be a wire breaking down or a fault with the gauge.

1988 Mk1 Golf GTi Cabriolet 1.8cc DX, K-jet. Daily drive. 290,000 miles and counting
1978 Mk1 Scirocco GLS 1.6cc FR, Webber carb. Weekend toy.

Post

Back to the top
Looks like this. I don't think this fits the k jet golf but looks the same. You can buy them from gsf, eurocarparts etc…
Expansion Tank Water Coolant Level Sensor VW Golf MK1 MK2 T25 Passat D-Jetronic | eBay

1988 Mk1 Golf GTi Cabriolet 1.8cc DX, K-jet. Daily drive. 290,000 miles and counting
1978 Mk1 Scirocco GLS 1.6cc FR, Webber carb. Weekend toy.

Post

Back to the top
if the above doesnt help then try bridging the level sensor opins. if that doesnt help pull the 42/43 relay. if that doesnt help then its the dash temp sensor, since the temp drops off as well id lean towards that. the light is both level and overheat warning, sometimes a faulty sensor can trigger the overheat warnign even if the temp displayed is ok!

the temp sensor is the black single pin jobber in the front or side flange on head, sometimes all they need is a good buff up and maybe a new spade fitting if its hanging off by a few strands of copper

Hello my name is John and I'm a dub addict.



My wiring diagrams and other documents have moved here:

VAG Documents & Downloads

You'll need to sign into google/gmail for the link to work! (its free!)

Post

Back to the top
Thanks guys, I think I had condensation in the level switch terminals, took plug off, dried off and gave terminals a clean and the light is off again thanks for the help

steve 

Post

Back to the top
ok keep an eye on it, sometimes the sensor leaks thru the pins and causes this! it can work its way up the wire like a wick and corrode the relay! most of the looms I work on have corrosion on these terminals to some extent

Hello my name is John and I'm a dub addict.



My wiring diagrams and other documents have moved here:

VAG Documents & Downloads

You'll need to sign into google/gmail for the link to work! (its free!)

Post

Back to the top
Ok thanks I will keep an eye on it
it steve 
1 guests and 0 members have just viewed this: None.